Service Alert
Incident Report for Ambassador Software
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 18:35 EDT
Investigating
Ambassador Software has been automatically notified of a service degradation or outage. Our team has been contacted and is investigating.
Posted Apr 09, 2024 - 12:29 EDT
This incident affected: API, Legacy Admin Portal, Legacy Ambassador Portal, Share Links, Web Integration, Email Services, and Social Services.