Custom domain sharelinks not working properly

Incident Report for Ambassador Software

Postmortem

The issue we had this morning with the DB performance impacted our sharelink system some hours later. The issue was fixed once we identified the root case

Posted Nov 03, 2025 - 15:43 EST

Resolved

All custom sharelinks are working well again
Posted Nov 03, 2025 - 15:41 EST

Monitoring

Isue identified, fixed and monitoring
Posted Nov 03, 2025 - 15:35 EST

Investigating

Some custom domains are not redirect to the right place
Posted Nov 03, 2025 - 14:59 EST
This incident affected: Share Links.