API high latency

Incident Report for Ambassador Software

Postmortem

Today a high database consumption impacted some API resources, those endpoints related to getting campaign information. The issue was solved by add some DB optimozation in these campaign DB operations

Posted Nov 03, 2025 - 10:12 EST

Resolved

Issue resolved by speedup some resources and database operations
Posted Nov 03, 2025 - 10:11 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 10:03 EST

Investigating

API response is slow down by a high resource consumption. We are tracking down the issue and block it
Posted Nov 03, 2025 - 08:56 EST
This incident affected: API.