Service Alert

Incident Report for Ambassador Software

Resolved

This incident has been resolved. Earlier this morning, our API and related services experienced approximately 15 minutes of elevated latency and intermittent errors caused by an unusually high burst of database load. Service fully recovered at around 10:42 EDT and has been stable since. We have identified the root cause and are implementing safeguards to prevent a recurrence. We apologize for any disruption.
Posted Jul 23, 2026 - 14:00 EDT

Investigating

Ambassador Software has been automatically notified of a service degradation or outage. Our team has been contacted and is investigating.
Posted Jul 23, 2026 - 10:43 EDT
This incident affected: API, Legacy Admin Portal, Legacy Ambassador Portal, Share Links, Web Integration, Email Services, and Social Services.