Weekly Maintenance Window
Incident Report for Ambassador Software
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 00:31 EDT
Investigating
We will be undergoing scheduled maintenance during this time.
Posted Oct 15, 2024 - 13:31 EDT
This incident affected: API, Legacy Admin Portal, Legacy Ambassador Portal, and Share Links.