New portal custom domain is failling

Incident Report for Ambassador Software

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:21 EDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 10:44 EDT
This incident affected: Modern Ambassador Portal.