Canada - Modern Admin service down

Incident Report for Ambassador Software

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 08:35 EST

Investigating

Canada - Modern Admin service down due to a AWS issue on the region, will be resolved soon
Posted Feb 13, 2026 - 08:07 EST
This incident affected: Canada (Admin Canada).