Service Alert
Incident Report for Ambassador Software
Resolved
We determined a specific client was undergoing a DDoS attack. Other clients were not affected.
Posted Jul 17, 2024 - 15:08 EDT
Investigating
Ambassador Software has been automatically notified of a service degradation or outage. Our team has been contacted and is investigating.
Posted Jul 17, 2024 - 01:09 EDT
This incident affected: API, Legacy Admin Portal, Legacy Ambassador Portal, Share Links, Web Integration, Email Services, and Social Services.